DVT IDE for VS Code SystemVerilog User Guide
Rev. 22.1.23, 16 August 2022

1.1 System Requirements

DVT for VS Code requires VS Code / VSCodium with minimum version 1.61.

Supported architectures are:

  • Linux x64

  • Linux aarch64

  • MacOS Intel (x64)

  • MacOS M1 (aarch64)

  • Windows x64

Recommended OSs for running VS Code or VSCodium are:

  • Linux: Ubuntu >= 16.04, RHEL >= 7, or other distros satisfying requirements for GLIBCXX version >= 3.4.21 and GLIBC version >= 2.15.

  • Apple macOS >= 10.11

  • Windows >= 8