DVT SystemVerilog IDE User Guide
Rev. 19.1.12, 19 April 2019

42.13 How to use Working Sets for filtering Problems/Task/Search views?

First of all, in general you can customize the contents of the Problems/Tasks/Search views by using the View Menu > Configure contents.

To see only the issues/tasks related to "your own code", you must first tell Eclipse what "your own code" means, and this can be achieved by using Working Sets.

For easier access to Working Sets related commands, you should first enable two command groups: go to Window > Customize Perspective > Command Groups Availability, and from the Available Command Groups list on the left select Window Working Set and Working Set Manipulation.

Now, there should be three new buttons in the Eclipse toolbar that allow you to select/deselect current working sets and add/remove resources from existing working sets.

  1. Modify workbench working sets

  2. Add the selected elements to a working set

  3. Remove the selected elements from a working set

Using the add/remove buttons you can craft one or more Working Sets to contain various sets of resources (i.e. files/folders). If you haven't created any working sets before you will be prompted to create a new one. Then, using the ' Modify Workbench Working Set ' button you can select several sets of resources form the ' Current Working Set '.

Finally, to achieve the Problems View/Tasks View filtering you require, you should create a filter ( View Menu > Configure contents > New) where the Scope should be ' On Working Set: Window Working Set '. With this filter activated, the Tasks and Problems views will only show the errors that are contained in the sets selected from the toolbar dropdown.