DVT SystemVerilog IDE User Guide
Rev. 19.1.43, 11 December 2019

40.10.8 Inspect View

Inspect View shows detailed information about various elements in DVT.

Open the view from menu Window > Show View > Other... > DVT > Inspect.

To inspect an element, simply select it in a view or click on its name in the editor.

Information about the selected element will be presented in the view.

Each element shown in the Inspect View starts with an information line regarding the file and line number of the element.

The Inspect View highlights the relevant source code lines of the selected element. These lines may be surrounded with additional source code to provide a context, if necessary.

You can customize the number of lines shown by going to Window > Preferences > DVT > Maximum Inspect View context lines, or by using the key mappings detailed in the Hotkeys chapter below.

For convenience, you can see the Inspect View embedded in diagrams by clicking the Inspect Panel... button in the toolbar.

Hotkeys

The following key mappings are available while interacting with the Inspect View.

CTRL + ALT + [Decrease the number of context lines shown
CTRL + ALT + ]Increase the number of context lines shown
CTRL + KCycle through highlighted inputs shown inside the view

40.10.8.1 WaveDrom Timing Diagrams

WaveDrom is a tool that draws timing diagrams (waveforms) from a simple textual description written in JSON. DVT renders WaveDrom waveforms in the Inspect View. The waveform diagram is updated on the fly (as you type).

The waveform description can be:

  • either embedded in comments, surrounded by @WAVEDROM_START...@WAVEDROM_END

  • or in files with *.json or *.json5 extensions

To save the diagram as an SVG file, right-click on it in the Inspect View.

DVT offers the ability to view WaveDrom diagrams through tooltips, by hovering over any waveform written inside DVT editors.

Tip: The WaveDrom documentation is available here.

Note: To specify additional file extensions, use the +dvt_wavedrom_file_ext_add+<extension> build config directive. To clear the extensions list use +dvt_wavedrom_file_ext_clear.

Note: By default, only waveform descriptions of maximum 5000 characters are rendered. You can change this threshold from menu Window > Preferences then DVT > Editors.

Note: DVT uses WaveDrom version 2.1.2.